Alertas de Ciberseguridad por Inyección de código PHP CGI instaladas en el sistema operativo Windows.

  • 10/06/2024
  • 6
Alertas de Ciberseguridad por Inyección de código PHP CGI instaladas en el sistema operativo Windows.

Fecha 10/06/2024
Importancia 5 - Crítica

Recursos Afectados
Esta vulnerabilidad afecta a todas las versiones de PHP instaladas en el sistema operativo Windows:

  • PHP 8.3, versiones anteriores a 8.3.8,
  • PHP 8.2, versiones anteriores a 8.2.20,
  • PHP 8.1, versiones anteriores a 8.1.29.

Las ramas de PHP 8.0, PHP 7 y PHP 5, también afectadas, están al final de su vida útil y ya no reciben mantenimiento.

Descripción
DEVCORE ha descubierto una vulnerabilidad de severidad crítica que podría permitir una ejecución de código.

Solución
Se recomienda encarecidamente que todos los usuarios actualicen a las últimas versiones de PHP 8.3.8 , 8.2.20 y 8.1.29.
También, se recomienda evaluar la posibilidad de migrar a una arquitectura más segura como Mod-PHP, FastCGI o PHP-FPM, ya que, PHP CGI es una arquitectura obsoleta.

Detalle
Esta vulnerabilidad de severidad crítica es de tipo inyección de código. El fallo se produce en la función 'Best-Fit' durante la conversión de codificación dentro del sistema operativo Windows. Se ha asignado el identificador CVE-2012-1823 para esta vulnerabilidad.